Jump to content

MAP sensor


Stevecooper10
 Share

Recommended Posts

hi, 

I have just collected my 2014 Astra SRI, 1.6 Diesel from the garage as the engine management light was on and car had gone into limp home mode. The diagnostic check revealed that the MAP sensor was working at 2% when it should have been 20%. The sensor was replaced and all seems well. When I collected the car the mechanic showed me the old sensor and in particular the amount of black residue on the filter attached to the sensor. There may be a problem down the line with the Turbo being clogged with the same residue and I'm keen to avoid this. My question is, is there anything I can put into the engine to clean this residue?? 

many thanks 

 

Link to comment
Share on other sites


Hi....welcome to the Club

It seems like the car was driven conservatively when it comes to engine revs.
A diesel needs revving to clear out the carbon deposits and keep everything clean and free to move.
Typical example of components affected by carbon build up....EGR, Turbo Vanes, DPF, etc
Good quality fuel and proper revs in lower gears will resolve this issue

Let us know how you get on with it all in the future.

Link to comment
Share on other sites

i think you may be right, my kids constantly berate me for driving too cautiously, I'll give it a good run and see what happens. I'm working from home more than before covid and the car was stood idle during the lock down so I guess that might be a factor. 

 

many thanks 

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...