Resetting the remaining oil life doesn't work - FIXED

Recommended Posts


I recently bought a 2012 Vauxhall Insignia, 2.0 CDTi auto estate car. The previous owner had just had the engine replaced and the oil had been changed (it appeared on the invoice). Unfortunately I didn't pick up on the fact that the oil life showed on the dash was... 32% (which is not okay if the engine and oil had just been changed).

On my way back home I tried resetting it from the car's menu, but that didn't work. Now I bought an Autel DiagLink diagnostics device, which has the oil reset feature... unfortunately when I reach the final step, it seems to get stuck (waited for a few minutes and it did nothing, nor could I get out of that menu).

Anyone been through such issues or has any solutions?

Thank you!

Edit: turns out I just didn't follow the right steps. Google helped me understand the operation needs to be done with the engine switched off and apparently I have to press the break pedal when pressing the reset button. Tried this and it worked.

Edited by Teodor
Solved my issue

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.