Jump to content

Car had no power


Recommended Posts

Posted (edited)

I drove my car to the local shop tonight no issues been driving it daily for almost 2 years. I got back in the car and there was no power at all. The hazards wouldn't even work. My brother came to tow me, then realised that it has an electric handbrakešŸ«£.

After about 20 minutes we were watching videos on how to manually release the electronic handbrake when all of a sudden the indicators flashed, got in and it started first turn of the key. šŸ¤·Ā 

Does anyone have any ideas at all to what it could be any ideas at all would be greatly appreciated.

14 plate vauxhall insignia ecoflex 2.0cdti

Ā 

Thanks everyoneĀ 

Ā 

Edited by adamcrake1
Link to comment
Share on other sites

Crikey thats an unusual one!

I would start at the battery terminals and work you way to the fusebox and look at fuses and relays as there must be a fault with the power distribution circuit
Start with the bigger cables (and connectors) and work your way through the smaller ones if not immediately obvious.
Don't forget to check earth cables and connection points

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

test

×
×
  • Create New...