Jump to content

clutch pedal not returning.


Recommended Posts

Hi All,

I have a insignia 2.0L CDTi 2011, i have just replaced the flywheel, clutch and concentric slave cylinder with a Sachs kit.

I have bleed the system with an ezibleed and manually with someone on the pedal but the clutch pedal will still not return and no pressure is felt on the pedal either, no fluid loss either.

Anyone experienced this.


Link to comment
Share on other sites

Update on the clutch pedal, i have flush through approx one litre of dot 4 fluid via the vacuum pump and it worked and i now have a pedal albeit when i drive the car it feels a little crunchy for some reason.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...